2

Abr

por Señor N

Llevo penando una época intentando hacer funcionar el sonido del paquete stepmania4_3.9+4.0cvs20071107-0~getdeb1_amd64.deb tal y como funcionaba antes, debido a alguna actualización del sistema de sonido de Ubuntu “Pulseaudio” me ha resultado imposible conseguir que funcione EL SONIDO, he probado scripts de carga, comandos internos del Pulseaudio que hacen cargar un programa fuera de su entorno de control, nada, modificaciones de los cargadores ejecutables, nada de nada.

La solución fue descargar el Stepmania 4 alpha 5 para windows e instalarlo con el Wine. Premio total. Funciona a la perfección, tomen nota frustrados usuarios de Ubuntu 9.10 x86_64. Hay solución por el momento.

Ya son 3 máquinas migradas a 64bits sin novedad.

He estado tuneando los sistemas por aquí y por allá, adaptando anteriores y optimizadas configuraciones al renovado sistema y ahora la cosa marcha bien, muy bien. Lo que más tiempo que me ha llevado en los equipos con entorno de escritorio, que en realidad no ha sido tanto, fue la optimización de Pulseaudio y los plugins del navegador.

Tras un tiempo de uso he sustituido el navegador que originalmente instalé Swiftfox para tener mis plugins de Flash(32bits) y Java(32bits) funcionando ya que las fuentes no las configuraba bien y el aspecto en general dejaba que desear.

El sustituto quasi-perfecto (está en inglés) hasta el momento ha sido Swiftweasel. Este nuevo proyecto paralelo a firefox de navegador “sin marca” tiene dos versiones, una de 64 y otra de 32 bits, originalmente tiene un repositorio para Ubuntu aunque yo lo he acoplado en mi Debian sin ningún problema, ahora mis fuentes se ven bien y tengo FLASH y JAVA. Una anécdota importante es un problema que me daba instalando extensiones (add-ons), daba un error -213 que me mandaba a revisar la consola de errores, la instalación de extensiones era totalmente fallida, tras investigar encontré un post que decía que HABÍA QUE BORRAR EL ARCHIVO extensions.rdf dentro del perfil del navegador, así lo hice y todo se resolvió.

Para instalarlo hay que añadir la línea al archivo sources.list:

deb http://download.tuxfamily.org/swiftweasel hardy multiverse

y luego instalar el swiftweasel32-athlon64 con:

apt-get install swiftweasel32-athlon64
(por ej. aunque yo uso aptitude)